• How do I upload the program with GNSS_View?

    Now I just get a bunch of junk in the serial monitor:

    „�:²� PKÒAà‰……’&’ZIÙ�¢‚šòL‰ŽÑ£¸à’x³È£Â#‚‰� ÁÓ.
    V’L‰ £‚Á¢Ôÿ£¢ ¡Ø"Ð,²ÒNäI2iåy¢ó#¢‰¡m Óð„’x”2Bƒ‚8¢,QÔÿ£‚AN‡²ÁSƒ.4£¢ ¢I
    3àkÆþ„�:²‘ ŃŠY¢‚"¢Ë„³¥

    What is going on with this junk?  Where is the quick guide for how to upload a program to the device?

  • You can upload your sketch by using the GNSS Viewer ( After verifying the sketch on Arduino IDE, the file should be located in C:\Users\YourUserName\AppData\Local\Temp. Select the correct COM port and baudrate, then use the download tab to upload the file.

    Otherwise, you can upload the sketch using default ROM. Connect the BOOT_SEL and RF_GND and press the reset button of the board to run ROM, then try uploading a sketch.  Once the sketch is uploaded, disconnect BOOT_SEL and RF_GND, then press reset again.

  • Ok tried on Windows 10 x64.  I get the same error on there: "NavSpark image failure. Error code : 4"

    I followed the pdf guid.

    I'm using Arduino 1.6.5.

    I have selected "NavSpark-GL" in Arduino.

    Processor: "Leon3 without GNSS library"

    Port: COM11

    My full output log:

    In file included from C:/Users/zezba/AppData/Roaming/Arduino15/packages/navspark/hardware/navspark/1.0.1/cores/arduino/Arduino.h:165,
    from C:/Users/zezba/AppData/Roaming/Arduino15/packages/navspark/hardware/navspark/1.0.1/cores/arduino/SkyTraq_NMEA_I2C.h:5,
    from C:\Users\zezba\AppData\Roaming\Arduino15\packages\navspark\hardware\navspark\1.0.1\cores\arduino\SkyTraq_NMEA_I2C.cpp:7:
    C:/Users/zezba/AppData/Roaming/Arduino15/packages/navspark/hardware/navspark/1.0.1/cores/arduino/GNSS.h:26:1: warning: "ULONG_MAX" redefined
    In file included from C:\Users\zezba\AppData\Roaming\Arduino15\packages\navspark\hardware\navspark\1.0.1\cores\arduino\SkyTraq_NMEA_I2C.cpp:6:
    C:/Users/zezba/AppData/Roaming/Arduino15/packages/navspark/tools/navsparktool/1.0.0/sparc-elf-3.4.4/bin/../lib/gcc/sparc-elf/3.4.4/include/limits.h:77:1: warning: this is the location of the previous definition

    LEON MKPROM prom builder for BCC v
    Copyright Gaisler Research 2004, all rights reserved.

    Section in rom detected, switching off compression

    creating LEON3 boot prom: prom.out
    1 file(s) copied.

    Sketch uses 91,904 bytes (8%) of program storage space. Maximum is 1,048,576 bytes.

    NavSpark image failure. Error code : 4

  • Good idea. Thank you, Andrew!

  • Ok thanks, might mention that the IDE / SDK installer instructions are located in the doc.  With the release notes just floating there, the page looks like its out of date or something is missing... like a download link used to go there but was removed, thus me looking for it on the web only to find the broken GitHub source.  Anyway just a suggestion.

  • Hi Andrew,

    1.5.6 r2 is no longer in use, moved to 1.6.5

    Please see section 10 of the user's manual on page-13:

  • I downloaded and build the IDE on Linux/Ubuntu 15.04 from source:

    The NavSpark-GL connects to "/dev/ttyUSB0" but when I try to deploy I get the error: "Unable to open /dev/ttyUSB0" and "Can't open /dev/ttyUSB0".

    Where is the official IDE download link from:

    There is a change-log but NO download to the actual application...??

This reply was deleted.