Garbled Serial Output

I just bought a standard Navspark, and attempted to just get serial output from the board. I set up the IDE (64 bit Linux), and uploaded a Hello World program:

void setup() 

void loop() 
    Serial.println("Hello world!");

It uploads successfully, but when I open the Serial Monitor I get a whole bunch of garbled text, like "BB!cXJ������)�T i�VFy...". The monitor is set to the correct baud rate, the processor is set to the one without GNSS library (I've tried switching it, it doesn't make any difference), and the board is set to "Navspark (GPS)", and I can't really think of anything else to check. Any suggestions?


You need to be a member of NavSpark Community to add comments!

Join NavSpark Community

Email me when people reply –


  • Hi again, sorry I haven't responded in a while. Been busy with school. I just tried uploading it using ROM mode, then removed the short and pressed reset, and I'm still getting garbage from the USB port. 

    Something else, a couple of the times I tried uploading the image in ROM mode, I got error code 8. Not really sure what that was, as I can't seem to find any reference to it. I was able to upload a couple tries later, so I don't think it's that big a deal.

    Lukas, I also tried pressing the reset button on its own, but it didn't seem to help. Thanks for the advice though.

    I'm really at a loss here, not really sure what might have gone wrong. Any other ideas?

  • Did you try resetting the board? I often get garbled output, which is fixed after I press the reset button. Guess something doesn't get properly synced before.

  • Strange, I ran the same code with GnssConf.init(), and my serial output is clean.  Which serial monitor are you using?  If it's still not working, upload your sketch using ROM mode (shorting BOOT_SEL with RF_GND and press reset once). After you finish uploading the sketch, remove the short and press reset again, and hopefully it doesn't output garbled text from GPIO 2 (TXD2).

  • Hi, I just tried that and it didn't work. Still getting a bunch of garbage.

  • Add GnssConf.init(); in setup.


    void setup()  {




This reply was deleted.